用户名: 密码: 登 录   个人中心   系统维护   用户注册  联系我们
当前位置 > 首页 > 缩略语细览

IP

标准号:AIR5645   标准名称: JAUS Transport Considerations      

基本信息

【名称】 IP
【英文名称】 Internet Protocol
【定义】 The internet layer of the TCP/IP protocol suite stack defining the packet format for message packets to be sent across an internet, and the protocol for delivering those packets to their intended destination. The protocol is Internet Protocol (IP); the packet defined is the IP datagram. See [RFC791].

同源缩略语

·ACK:Generally, a byte or message sent to acknowledge successful receipt of a packet or message. Specifically, the ASCII control character octet of value 0x06.
·ADCCP:ADCCP is an ANSI standard derived from IBM’s SDLC (Synchronous Data Link Control). As such, ADCCP is a bit-oriented synchronous data-link layer protocol, and is very similar to the ISO HDLC (High-level data link control) standard, which also derives from SDLC.
·ANSI:ANSI is a non-governmental, non-profit standards organization, overseeing the development and administration of technical standards in the United States. ANSI is the official U.S. representative to the ISO.
·ARQ:A transport protocol is said to be an ARQ protocol if it uses positive and negative acknowledgements and sender timeouts, and further employs packet replacement on request to overcome packet loss or corruption over noisy or unreliable channels.
·ASCII:ASCII is a character encoding for digital representation of the English alphabet, for representation of text in computers and digital communications.
·CRC:An error check algorithm based on polynomial division over a binary field.
·CRC-CCITT:A specific CRC, defined by its polynomial, initial conditions for accumulation, and terminal conditions, as defined by ITU Recommendation X.25 (which was once CCITT recommendation X.25).
·CPPP:A variant of PPP (point-to-point protocol) incorporating a form of TCP header compression (Van Jacobsen header compression).
·CSLIP:A variant of SLIP (serial line internet protocol) incorporating a form of TCP header compression (Van Jacobsen header compression).
·DHCP:DHCP is a protocol (set of rules) used by network clients to obtain an IP address and other networking parameters (such as the subnet mask and the IP addresses of DNS servers and default gateway) from a server providing network management services.
·DLE:An ASCII control character, an octet of value 0x10, this character is used in the implementation of data transparent protocols such as those consistent with [X3.28].
·DNS:A fundamental element of internet infrastructure, the Domain Name System translates human- readable hostnames to IP addresses.
·EMI:Interference by electromagnetic signals that can cause reduced data integrity and increased error rates on communication channels.
·FIFO:This term describes a simple queuing technique in which requests, data, or processes are handled in order of arrival; the term also is used as a noun, describing an instance or implementation of a queuing mechanism with that handling behavior.
·HMI:See “OCU – Operator Control Unit”
·IANA:The IANA is responsible for assignment of IP addresses, top level domains and Internet protocol code point allocations (such as port assignments). The IANA assignment data is maintained on the IANA website, http://www.iana.org.
·IETF:The engineering body responsible for technical specifications, definitions and direction for the continued development of internet technologies.
·IPS:The protocol suite defines network communications using the TCP/IP family of protocols.
·ISO:A non-governmental organization that leverages the activities of the national standards organizations of 146 countries, ISO is the largest developer of technical standards in the world.
·JAUS:A suite of standards used in the research, development, design, acquisition and deployment of Unmanned Systems.
·JPEG:This committee created a standard of the same name, defining means of encoding and compressing image data into a stream of bytes, and of decompressing that stream into an image; both lossy and lossless compression techniques are defined. The standard also defines the file formats for storing the stream of bytes.
·MSN:A unique identifying “serial number” assigned to packets as transmitted; the MSN is typically used in the detection of missed messages, in providing assurance of correct sequence of delivery, and in the requesting of retries when multiple outstanding messages are supported.
·MTU:The Maximum Transfer Unit (MTU) is a term for the size of the largest datagram that can be passed by a layer of a communications protocol.
·NAK:Generally, a byte or message sent to indicate unsuccessful receipt or non-receipt of a packet or message. Specifically, the ASCII control character octet of value 0x15.
·OCU:A device by means of which a human operator may control an Unmanned System.
·OSI:A data communications model developed by ISO to assure communications interoperability across disparate systems.
·PDU:An application message (for the purposes of this specification, this will be assumed to be a JAUS message) being propagated down the protocol stack on the sender side, or up the protocol stack on the receiver side.
·PPP:An encapsulation protocol for sending IP datagrams across serial communications links, PPP also incorporates strong blockchecks, control protocols and a high degree of configurability. [RFC1661]
·RF:Electromagnetic energy or signaling based thereon whose frequency is normally associated with radio wave propagation.
·SLIP:An encapsulation protocol for sending IP datagrams across serial communications links. [RFC1055]
·TCP:A reliable, connection-oriented message delivery protocol defined by [RFC793] and related IETF documents.
·UAV:An unmanned aerial vehicle; may be teleoperated or autonomous.
·UGV:An unmanned ground vehicle; may be teleoperated or autonomous.
·USV:An unmanned surface-of-water vehicle; may be teleoperated or autonomous.
·UUV:An unmanned undersea vehicle; may be teleoperated or autonomous.
·UDP:An unreliable best-effort connectionless message delivery protocol defined by [RFC768] and related IETF documents.
·XML:A general purpose markup language providing users the ability to define their own tags. XML is a simplified subset of an earlier markup language, SGML (Standard Generalized Markup Language).